FFmpeg Audio Studio › 帮助

帮助

什么是 FFmpeg Audio Studio?

FFmpeg Audio Studio 使用 ffmpeg 作为引擎,将音频文件从一种格式转换为另一种格式。您添加文件,选择预设,然后转换;结果会放在原始文件旁边或您选择的文件夹中。它可以读取 ffmpeg 可以解码的任何内容,并写入十八种格式,从 MP3、AAC、FLAC、Opus 和 Ogg Vorbis 到 WAV、AIFF、WMA 和 iPhone 铃声格式。

它的独特之处在于,三个选择是分开进行的,每个选择都来自窗口右侧选项面板中的自己的下拉菜单:预设(输出是什么)、标签设置(保留哪些标签和封面)和效果设置(对声音进行什么操作)。因此,一个预设可以与剥离注释的设置一起使用,也可以与规范化音量的设置一起使用,或者两者都不使用。标签也以标签编辑器显示的名称从一种格式传输到另一种格式,因此一个字段从 FLAC 到 MP3 到 M4A 到 WMA 都保持其含义。

FFmpeg Audio Studio 有两个视图,由标题的头两个按钮选择。工作视图首先打开:一次一个文件,带有其波形、应用了效果的真实播放、剪切、淡入淡出以及声音通道、均衡器、压缩器和电平的抽屉(请参阅工作视图)。批处理视图适用于许多文件:文件列表、带有文件操作的标题、右侧带有塑造运行的选择的面板——预设、标签、效果、目标以及当文件存在时如何处理——以及在其底部,一次转换的数量、转换和打开输出文件夹的按钮,以及带有状态行的底部栏。除非另有说明,本页的其余部分描述了批处理视图。

  • 工作: 一次处理一个文件 显示工作视图。
  • 批处理: 使用预设转换多个文件 显示批处理视图。

工作视图

工作视图一次处理一个文件:您可以听到转换后的声音,通过查看波形设置剪切点和淡入淡出,然后从那里进行转换。将音频文件拖放到左侧空白区域(将音频文件拖放到此处进行收听或编辑),或从波形下方的文件列表中选择;拖放文件夹将被忽略。未选择文件时,该区域会显示“尚未听到任何内容”。

  • 显示文件列表 在抽屉替换文件列表后再次显示文件列表。
  • 隐藏图片下方的面板 隐藏波形下方的面板,显示图片下方的面板 将其恢复。

波形和播放

波形是从文件本身绘制的。播放它会运行 ffmpeg 并应用您已开启的效果,因此您听到的声音就是转换后的文件听起来的样子,除了最终编码。在播放时更改文件或效果会从您所在的位置重新开始播放声音。如果某个效果无法在预览中听到,则会将其省略,并且行 从声音中排除 会命名它;转换仍然会应用它。

  • 播放 和 暂停 启动和停止声音。
  • 后退一秒 和 前进一秒 将位置移动一秒。
  • 音量 是您收听的音量,静音 和 取消静音 使其静音和恢复。它只改变您听到的声音,从不改变文件。
  • 正在测量声音... 在需要先听取整个文件的效果(例如响度标准化)测量文件时显示。

剪切

剪切会保留文件的一部分。标记为 [ 和 ] 的按钮用于设置剪切的开始和结束位置,点击波形图可以移动位置。被丢弃的部分会变暗。剪切是文件效果的一种设置,因此它会被写入转换后的文件,仅预览不会进行任何剪切。

  • 在此处开始切割 和 在此处结束切割 设置剪切的开始和结束。
  • 转到切割起点 和 转到切割终点 将位置移动到剪切的开始和结束。
  • 保留整个文件 移除剪切并保留整个文件。
  • 持续时间 是剪切后将被写入内容的长度。

淡入淡出

淡入和淡出是波形上的两个手柄,分别位于保留部分的每一端。拖动一个手柄可以延长或缩短其淡入淡出时间,或者在波形下方的数字框中输入秒数。淡入淡出始终保持在保留部分内,并且两个淡入淡出永远不会重叠。零秒的淡入淡出表示没有淡入淡出。

抽屉

波形图下方有一排按钮,用于选择面板显示的内容:文件列表,或一次显示一个抽屉。每个抽屉都是一个效果的控件,使用它会在工作视图列表中打开该效果,因此您设置的内容会立即听到并写入文件。

  • 通道抽屉显示了处理通道的方式的磁贴:左右声道互换、单声道在两边播放、将两者混合成一个通道,以及混音到立体声。文件的通道不是预设的一部分:它们是这种效果,因此只有当您选择一个磁贴时文件才会更改。当应用程序首次启动时,从早期版本携带通道选择的预设将转换为此效果。
  • 均衡器抽屉将十个频段绘制成一个曲线图,横轴是频率,纵轴是增益。
  • 压缩器抽屉将其两个控件绘制成曲线:每个输入电平对应的输出电平。
  • 电平抽屉提供了四种设置音量的方式——固定增益、响度、峰值或 ReplayGain——一次只使用一种:选择另一种会替换第一种。所选方式的每个数字都是一个可拖动的推子。

工作视图的效果列表

工作视图自己的列表,音频效果,位于波形图下方。它不是批处理视图中保存的效果条目之一:它属于工作视图,其中包含的内容是预览播放和转换应用的内容。标准效果始终以带有开关的行形式存在,顺序固定,因此您可以通过打开和关闭来尝试;其他效果则从添加效果添加,如添加效果所述。

旁边,工作视图有自己的文件选择:预设音频、标签设置(标签)、目标和如果存在,它们的作用如预设、标签和目标部分所述。

  • 设置的ffmpeg选项卡上的工作视图中列出的效果选择列表中显示哪些效果可供打开;其余的保留在添加效果菜单中。应用程序围绕构建的效果始终会列出。返回标准列表返回标准列表。

ffmpeg 命令

文件列表下方的一个面板会显示所选文件将用于转换的精确 ffmpeg 命令,包括效果和剪切,因此您可以阅读或自行运行它。未选择文件时,会显示相应提示。

  • ffmpeg 命令 是该面板,而 复制 将命令复制到剪贴板。

添加文件

通过选择文件、选择整个文件夹或将文件拖放到窗口中来构建要转换的文件列表。每行都显示文件中嵌入的图片作为小缩略图,如果没有图片则显示音符。

  • 添加文件 打开文件选择器。只提供 ffmpeg 可以读取的音频文件。
  • 添加文件夹 添加一个文件夹;会找到其中以及其下所有文件夹中的音频文件。文件夹的名称会被记住,以便在目标中重建结构(请参阅目标)。
  • 清空列表 清空列表中所有未正在转换的行。
  • 从列表中移除 是单行的按钮;当一行正在转换时,同一个按钮会改为取消它。

列表

文件添加一次后,再次添加相同文件不会有任何操作。已完成、已跳过、已失败或已取消的行会保留在列表中,并在您下次按下转换时,根据其自己的设置再次转换。

每个文件都有自己的设置 - 包括其预设、标签设置、效果设置、目标位置以及文件存在时的处理方式。您添加的文件会采用选项面板当前显示的选择,并且之后只选择新添加的文件。面板就像一把刷子:它从不显示行的选择,选择行也不会改变它。要为其他文件提供不同的选择,请选择它们,设置面板,然后按下 应用:它会将面板的所有选择写入到未排队或未运行的选定行中,并且在未选择任何内容时处于关闭状态。通过单击、按住 Ctrl(或 Cmd)并单击来添加或删除行、按住 Shift 并单击以选择从上次单击开始的范围,或按 Ctrl+A 选择所有行;单击列表的空白部分会清除选择。底部栏会显示已选择的行数。

每行显示一个小的芯片,代表一个选择 - 预设、标签设置、效果设置、目标位置和如果存在策略。保持一切不变的选择会被省略,因此一个普通的行只显示其预设。

  • 应用 将面板的选择应用于选定的文件。

转换

按下转换以运行所有尚未排队或正在运行的行。每个文件都是一个独立的作业,因此一个失败永远不会停止其他作业,并且失败的行会显示原因。

  • 转换 转换所有未排队或正在运行的行,每行都有自己的设置(参见文件列表)。如果某行自己的选择只会将其重新编码为原样,则无需执行任何操作,并将其排除。
  • 停止 在运行期间出现,并取消所有已排队或正在转换的文件;部分写入的输出将被删除。
  • 行上的 取消 会取消该文件。

行徽章的含义

行会按顺序通过其状态,徽章显示它所处的状态。

  • 已排队 等待空闲位置。
  • 正在读取 正在检查文件。
  • 正在分析 后跟百分比表示文件在转换前正在读取,因为某个效果需要其中的数字(声音的开始和停止位置,响度);它只在那时出现。随后的转换是根据输出长度测量的,因此修剪过的文件仍然达到百分之百。
  • 百分比是转换本身,根据输出将具有的长度进行测量。
  • 完成 完成;该行还显示文件去向。
  • 已跳过 输出已存在,并且目标指示跳过它。
  • 失败 出现问题;原因显示在该行上。
  • 已取消 您已停止它。

左下角的状态行显示运行前有多少文件已准备好,运行期间处理了多少文件,以及之后的结果:有多少文件已转换、已跳过和已失败。

同时处理文件

选项面板最后一行的“转换”旁边的数字,用于选择同时转换的文件数量,范围从一个到机器的物理核心数,这也是默认值。编码受处理器限制,因此超过核心数的进程只会争夺相同的核心和磁盘:在八核十六线程的机器上,同时处理十六个文件比处理八个文件要慢,因此不提供超过物理核心数的选项。当计算机需要保持响应时,请降低此值。

  • 悬停在其上方时,其名称为 同时转换的文件。

当“转换”按钮呈灰色时

当没有行需要处理时,“转换”按钮将关闭:对于每一行,其预设、标签设置和效果设置都不会改变任何内容——预设为“(原始)”,标签设置不删除任何标签或封面,并且未选择任何效果。转换只会重新编码每个文件,这会无谓地损失质量。对某些行应用其他预设、删除某些内容的标签设置或效果,它就会恢复。当没有文件列出、正在运行以及未找到 ffmpeg 时,它也会关闭。

预设:格式及其质量

预设说明了输出是什么:格式、质量以及该格式的选项。它在选项面板的第一个下拉菜单中选择,并在设置的预设选项卡中编辑,该选项卡由下拉菜单旁边的按钮打开。

  • 编辑预设 打开预设选项卡。
  • 新建、复制 和 删除 用于添加预设、复制选定的预设和删除预设。始终至少有一个预设。
  • 预设通过拖动其行来移动;面板的下拉菜单中也使用相同的顺序。

预设

全新安装附带一组现成的预设(128、192 和可变高质量的 MP3、AAC、Opus、WMA、AC-3、iPhone 铃声、Ogg Vorbis、FLAC、WAV 16 位和 AIFF 16 位)。它们是普通的预设:可以重命名、编辑或删除它们。iPhone 铃声被剪切为 40 秒,这是 iOS 接受的最长长度。

  • 名称 是下拉菜单中显示的名称。
  • 格式 是输出格式。下面的选项随之而来:格式只显示它实际拥有的控件。

质量

每种格式都有一个主要的质量设置,一个数字字段及其旁边的单位,其含义遵循格式:MP3、AAC、Opus、WMA 和 AC-3 的比特率(kbps);Ogg Vorbis 和可变 MP3 的可变质量级别;FLAC 和 WavPack 的压缩级别,这只会改变编码所需的时间和文件大小,而不会改变声音。WAV 没有质量设置。更高的比特率或级别意味着更大、音质更好的文件。

  • 比特率模式(MP3 和 Ogg Vorbis)选择编码器如何分配其比特:固定 在整个过程中使用相同的比特率,可变 根据音乐调整以获得更好的大小与质量比,而 平均 (ABR)(仅限 MP3)则旨在达到平均值。
  • 比特率 是恒定和平均模式的比特率。
  • 质量等级 是可变模式的级别。
  • 压缩 是 FLAC 和 WavPack 的压缩级别。

采样率和位深度

这些描述了音频的形状。如果保持源文件不变,输出将具有与输入相同的值;更改它们会重新采样。只提供格式接受的值。声道(交换、两侧相同、混音为单声道或立体声)是一种音效,位于音频效果列表中。

  • 采样率 是输出每秒的采样数。
  • 位深度 是对于具有采样大小的格式(FLAC、ALAC、WAV、AIFF 和其他一些格式)而言,每个采样的大小。

抖动

当24位录音转换为16位时,样本会被四舍五入,这种四舍五入会留下微弱的失真,在安静的段落中可以听到。抖动首先会添加极少量的噪声,将这种失真转化为远低于音乐的稳定嘶嘶声。默认是普通四舍五入,对大多数音乐来说已经足够;抖动适用于安静、高分辨率的母带。它从不应用于24位输出。

  • 抖动 (当输出为 16 位时) 在输出为16位时出现。

ID3 标签版本

MP3、AIFF 和 WAV 输出带有 ID3 标签,版本为 2.3 或 2.4。版本 2.3 可被所有播放器读取,并且是 Mp3tag 默认写入的版本;2.4 是较新的版本,以 UTF-8 存储文本。两者都将重复字段作为单独的值保存。除非有特殊需求,否则请保持在 2.3 版本。

  • ID3 标签版本 选择版本。

高级选项

在常规控件下方,有一个折叠部分,其中包含编码器除了质量设置之外的开关。如果保持不变,编码器会自行决定,并且从未打开该部分的预设会生成与之前相同的文件。除非您知道自己想要什么,否则请勿更改它们。

  • 高级选项 是该部分;在您设置之前,每个条目都是 自动。
  • MP3:联合立体声、编码器质量 (0 最佳, 9 最快)、低通滤波器 (Hz)、高通滤波器 (Hz)、使用比特储备、设置版权标记 和 设置原始标记。
  • Ogg Vorbis:最小比特率 (kbps) 和 最大比特率 (kbps) 将其切换到比特率目标模式。
  • Opus:优化用途(音乐、语音或低延迟)、比特率模式、帧大小、复杂度 (0 到 10)、带宽 和 强度立体声相位反转。
  • FLAC:块大小、立体声模式、最大LPC阶数、LPC系数精度、最小分区阶数、最大分区阶数 和 穷举模型搜索。
  • AAC:带宽限制 (Hz) 限制保留的最高频率。

(原始)

预设下拉菜单的第一个选项不是预设:(原始) 将每个文件转换为保留其自身音频编解码器的格式,并保持其原有的比特率。它适用于仅需更改标签或声音,而无需更改格式的任务。如果某个编解码器没有输出格式支持(例如 APE),则该文件会转换失败,并在其行中显示一条消息。它无法编辑或删除。

目标:文件去向

目标是选项面板中选择并在设置的目标选项卡中编辑的文件夹加上命名文件的模式。

  • 编辑目标 打开目标选项卡。
  • 转换后的文件写入位置 是选项面板的目标下拉菜单。
  • 名称 是下拉菜单中显示的名称。
  • 文件夹 是文件写入的位置,浏览 选择它。相对文件夹,例如 convert、.\convert 或 ..\convert,是从每个文件的文件夹计算的:.\convert 是文件旁边的 convert 文件夹,..\convert 是其文件夹旁边的文件夹,因此单个条目适用于位于许多文件夹中的文件。此时不保留文件夹结构,因为文件所在的文件夹已经是结构。诸如 D:\Out 之类的完整路径是每个文件的唯一位置。

源文件夹

第一个条目,源文件夹,是内置的:每个输出都写在其原始文件旁边,并保留其名称,但带有新的扩展名。它不需要文件夹,也无法编辑。

文件名模式

该模式根据每个文件的标签命名输出文件。点击一个标签即可添加;斜杠会创建一个子文件夹。标签包括原始文件名、标题、艺术家、专辑艺术家、专辑、曲目号、碟号、年份和流派。

  • 文件名模式 是模式。文件缺少标签会生成一个被删除的空部分,但缺少艺术家或专辑会显示“未知艺术家”或“未知专辑”,缺少标题则会回退到原始文件名。
  • 示例 显示一个虚构文件将被如何命名,以便您在使用前检查模式。

如果模式是艺术家、专辑、曲目和标题,中间用破折号连接,那么一个标签为 Björk、Homogenic、3、“Jóga”的曲目将保存为 Björk/Homogenic/03 - Jóga.mp3;曲目号会填充到两位数,并且文件系统禁止的字符会被替换。

保持文件夹结构

添加文件夹时,其子文件夹可以在目标文件夹下重建,从而保持专辑树的结构。添加文件夹本身的名称也会保留,因此两个添加的文件夹仍然是两个文件夹。单独添加的文件没有文件夹可保留。

  • 转换文件夹时保留文件夹结构 默认开启。

如果文件已存在

当输出文件已存在同名文件时会发生什么。输出文件永远不是输入文件本身。

  • 当输出文件已存在时如何处理 是选项面板中的下拉菜单。
  • 跳过(默认)保留现有文件并将该行标记为“已跳过”。
  • 覆盖 替换现有文件。
  • 保留两者 将新文件以编号名称写入其旁边,例如 name (2).mp3。

打开输出文件夹

  • 打开输出文件夹 打开最新完成文件的文件夹,在任何文件完成之前,则打开目标文件夹本身。

标签:保留什么,删除什么

标签是文件内部的标题、艺术家、专辑、年份、曲目编号以及其他信息,以及封面图片。标签设置决定了其中哪些信息会输出。它在选项面板的第二个下拉菜单中选择,并在“设置”的标签选项卡中编辑;编码和要删除的元数据是独立选择的,因此一个预设可以同时用于两者。

  • 标签 是下拉菜单。
  • 编辑标签 打开“标签”选项卡。
  • 名称 是条目的名称。
  • 条目的添加、复制、删除和拖动排序方式与预设相同。

保留所有,或删除所有

一个条目有一个模式和一份例外列表。

  • 保留所有标签 保留所有标签;列表包含要删除的标签(例外:要删除的标签)。
  • 删除所有标签 删除所有标签;列表包含要保留的标签(例外: 要保留的标签)。
  • 标签 是两者之间的选择。

全新安装时有一个条目,“保留所有标签”,列表为空。要删除嘈杂的字段,请保留默认模式并将其列出;要只保留基本信息,请切换到删除所有内容并列出 TITLE、ARTIST、ALBUM 和 TRACK。

命名标签

每行写入一个名称,或用分号分隔,就像您的标签编辑器显示的那样。名称不区分大小写,星号匹配任何文本,因此 REPLAYGAIN_* 匹配所有 ReplayGain 字段。无论格式如何拼写字段,名称都会匹配:编辑器的名称 (ENCODERSETTINGS)、ID3 帧 ID (TSSE)、Vorbis 名称或自定义字段的描述。当您输入时,框下方会提供符合条件的已知字段名称;点击一个即可使用。任何名称都接受,无论是否提供。

封面图片

图片不是标签名称,因此它有自己的开关,并且删除所有标签的模式永远不会触及它。

  • 移除封面图片 将封面排除在输出之外。

歌词

歌词与其他标签一样,分为两种:纯文本歌词和带时间戳的歌词,其每行都以 [01:23.45] 这样的时间开头。FLAC 文件将这两种歌词都保存在一个歌词字段中,因此 FFmpeg Audio Studio 会读取文本:当至少两行以时间开头时,它就是带时间戳的歌词。MP3、AIFF 文件或 WAV 文件的 ID3 部分为每种歌词类型都有一个帧——SYLT 用于带时间戳的歌词,USLT 用于纯文本歌词——源文件中 SYLT 帧中包含的带时间戳的歌词会作为 .lrc 文本保留下来,因此在转换为任何格式后都能幸存。

  • 将 .lrc 文件嵌入为歌词 会获取与源文件同名且位于源文件旁边的 .lrc 文件,并将其文本作为新文件的歌词。它会替换源文件已有的任何歌词,并且删除歌词的标签条目无法将其移除。
  • 标签中的歌词 选择 ID3 输出获取哪些帧:自动(带时间戳歌词为 SYLT,纯文本歌词为 USLT) 根据文本选择一个帧写入,两个帧(USLT 和 SYLT) 写入两个帧,始终 USLT 和 始终 SYLT 无论文本如何都写入该帧(纯文本歌词在 SYLT 中每行的时间都为零)。它对其他格式无效,因为它们将文本保存在自己的歌词字段中。
  • 写入 USLT 时移除时间戳 从写入的每个 USLT 帧的文本中移除时间戳;SYLT 会保留其时间戳。

标签如何在不同格式之间传输

仅凭 ffmpeg 会重命名它不认识的字段并删除一些其他字段。FFmpeg Audio Studio 将每个字段以标签编辑器用于该格式的名称写入,因此专辑艺术家、排序字段、作曲家、BPM、歌词、ISRC 和自定义字段在不同格式之间保持其含义。具有多个值的字段保持为单独的值,音轨或光盘编号以其总数(3/10)写入支持这样做的格式,存储不当的年份不会丢失,并且源以两种不同值(PUBLISHER 和 ORGANIZATION)拼写两次的字段会保留两者:第二个字段保持为自己的字段而不是被覆盖。封面会随之传输到所有可以容纳封面的格式;例外情况是 Ogg 中的 FLAC、iPhone 铃声和 AU,它们不包含封面。原始流(AC-3、原始 AAC、MP2、Wave64)根本不包含标签和封面。

(无)

标签下拉菜单的第一个选项 (无) 不是一个条目:它会毫无例外地保留所有标签和封面。它不能被编辑或删除。

效果:对声音进行的操作

效果条目是对声音进行转换时所执行操作的命名列表。此列表在此处和工作视图中称为“音频效果”。它在选项面板中选择,与预设分开,因此一个条目可以与任何预设一起使用,并在“设置”的音频效果选项卡上进行编辑。

  • 编辑效果 打开效果选项卡。
  • 新建、复制 和 删除 用于创建、复制和删除条目;拖动行可更改列表的顺序。
  • 名称 是条目的名称。
  • 添加效果 将效果添加到条目(请参阅添加效果)。
  • 关闭所有效果 关闭条目的所有卡片,同一按钮再次打开它们(展开所有效果)。
  • 拖动以更改此效果的运行时间 是卡片左侧的抓手;移除此效果 从条目中删除效果。
  • 恢复默认 是设置旁边的按钮,可将其恢复为默认值。

效果条目

效果在列表中时处于开启状态,移除时则关闭;没有单独的开关。同一个效果可以多次出现在列表中,每次都有自己的设置。在页面上,每个效果都是一张卡片:一个在卡片关闭时仍然可见的标题(抓手、效果名称、移除按钮)以及其下方的设置。在设置下方,卡片会显示它所写入的 ffmpeg 命令,因此您可以确切地看到将要运行的内容。

添加效果

添加效果 是一个与搜索框连接的类别按钮。类别按钮提供全部 或一个类别,并将菜单缩小到该类别;在搜索框中输入内容会按名称缩小菜单。选择一个效果会将其添加到列表末尾,并带有其默认值,然后您可以将其拖动到所需位置。除了为应用程序制作的效果外,菜单还提供 ffmpeg 自己的滤镜,每个滤镜都带有 ffmpeg 提供的选项。

效果运行的顺序

效果按照您放置的顺序,从列表顶部到底部运行,因此拖动卡片可能会改变结果。有些步骤无论在列表中何处,都会由应用放置在特定位置,因为它们必须在某个特定点查看文件:例如文件的剪切或大小限制。当某个顺序无法给出您预期的结果时(因为某个效果依赖于后续效果所更改的内容),卡片下方会显示一行文字说明。应用绝不会重新排序您的列表。

所有效果

以下是应用程序按类别提供的效果,以及每个效果的功能。名称和句子来自与 ffmpeg 一起安装的效果目录,因此它们遵循您拥有的 ffmpeg 版本;在 ffmpeg 安装之前,效果选项卡会显示效果尚未安装。

时间与帧 - 帧技巧:延时摄影、平滑运动、填充

  • 倒放: 从片段末尾到开头播放,包括声音。整个片段会保存在内存中。

音量与动态 - 增大、减小、均衡、压缩、限制、门限、标准化

  • 动态标准化: 均衡音量,使安静和响亮部分保持一致。
  • 动态均衡器: 一种增益随声音电平变化的均衡器。
  • 动态平滑: 平滑声音中突然的跳变。
  • 多频段压缩器: 独立压缩每个频段。
  • 频谱动态范围控制: 单独控制每个频段的电平。
  • 软削波器: 柔和地削平峰值,而不是直接切断。
  • 限制器: 阻止声音超过某个电平,而不会出现硬削波。
  • 响度标准化: 将声音调整到标准响度 (EBU R128)。
  • 心理声学削波器: 以人耳不易察觉的方式削波响亮的峰值。
  • 压缩器: 高于某个电平的所有声音都按比例降低,使响亮和安静的部分更接近。
  • 压缩器/扩展器: 使用您设置的传输曲线压缩或扩展动态范围。
  • 移动直流电平: 将整个波形向上或向下移动。
  • 音量: 使声音变大或变小。
  • 音量:峰值标准化: 将最高采样点调整到目标电平。
  • 音量:固定增益: 以固定量使声音变大或变小,带有限幅器。
  • 音量:响度标准化: 将保留部分的响度调整到目标值,并带有限幅器以防止增益削波。
  • 音量:应用 ReplayGain: 将音轨(或专辑)的 ReplayGain 增益应用到声音本身,带有限幅器。
  • 音频对比度: 通过轻微扩展或压缩音频动态,使声音更具冲击力。
  • 语音标准化: 将语音调整到均匀的水平。
  • 噪声门: 当声音低于某个电平时将其静音。
  • ReplayGain:写入标签: 将新文件的音轨增益和峰值写入标签;声音本身未受影响。

均衡器与滤镜 - 低音、高音、保留或削减频率范围

  • 18 段均衡器: 一个具有18个固定频段的均衡器。
  • 表达式生成声音: 用公式重写声音的每个采样。
  • 参数均衡器: 多频段均衡器,每个声道有独立的曲线。
  • 带通滤波器: 保留一个频段,移除其余部分。
  • 带阻滤波器: 移除一个频段,例如嗡嗡声。
  • 低频搁架: 提升或削减某个频率以下的所有声音。
  • 低通滤波器: 去除高于限制的频率:嘶嘶声。
  • 低音: 提升或削减低频。
  • 高阶带通: 使用非常陡峭的滤波器保留一个频段。
  • 高阶带阻: 使用非常陡峭的滤波器移除一个频段。
  • 高频搁架: 提升或削减某个频率以上的所有声音。
  • 高通滤波器: 去除低于限制的频率:隆隆声、嗡嗡声。
  • 高音: 提升或削减高频。
  • 均衡器(单频段): 提升或削减一个频段的频率。
  • 均衡器(十段): 从 31 Hz 到 16 kHz,每个八度频段的增益。
  • 频率偏移: 将所有频率向上或向下移动一个固定量。
  • 频谱倾斜: 调整低频和高频之间的平衡。
  • 频域表达式滤镜: 通过应用于频率的公式改变声音。
  • 倾斜搁架: 一种搁架滤波器,可倾斜整个频率平衡。
  • 全通滤波器: 改变声音的相位而不改变其响度。
  • 声音导数: 计算声音的变化率,一种信号处理工具。
  • 声音积分: 计算声音的运行总和,一种信号处理工具。
  • 系数双二阶滤波器: 应用您以数字形式给出的二极二零滤波器。
  • 系数IIR滤波器: 应用您以数字形式给出的无限脉冲响应滤波器。
  • 相位偏移: 偏移所有频率的相位。
  • 削减超低音: 移除最低频率。
  • 削减超高频: 移除听力范围以上的频率。
  • 预加重 (RIAA 及其他): 应用或撤销录音预加重曲线,例如 RIAA。
  • 增强低音: 添加超低音范围的频率。
  • FIR 均衡器: 一个具有自定义曲线的精确均衡器。

噪声与修复 - 嘶嘶声、咔嗒声、削波、嗡嗡声、齿音

  • 降噪 (非局部均值): 使用块匹配方法减少宽带噪声。
  • 降噪 (小波): 使用小波减少噪声。
  • 降噪 (FFT): 使用频率分析减少嘶嘶声等稳定噪声。
  • 解码 HDCD: 解码高清晰度兼容数字光盘。
  • 去齿音: 柔化语音中刺耳的s音。
  • 修复削波: 恢复因电平过高而被削掉的峰值。
  • 移除咔嗒声: 去除短促的咔嗒声和爆裂声,例如老唱片中的声音。
  • 语音降噪 (神经网络): 使用训练过的神经网络减少语音中的噪声。

时间与音高 - 淡入淡出、速度、音高、剪切、循环、静音

  • 保留范围: 仅保留两个时间点之间的部分,根据其上方效果保留的内容计算。
  • 不重采样改变速率: 以不同速率播放相同的采样:音高和速度同时改变。
  • 淡入淡出: 在保留部分的开头,声音从静音淡入,并在结尾淡出至静音。每个时长以秒为单位;0表示该端保持不变。
  • 淡入或淡出: 在选定时间内淡入或淡出声音。
  • 改变速度,保持音高: 在不改变音高的情况下使声音变快或变慢。
  • 剪切声音: 保留声音的一部分,丢弃其余部分。
  • 结尾静音: 在歌曲的尾部静音开始处剪切,并在其后精确保留指定长度的静音,以便 LP 作为独立音轨播放。
  • 静音填充: 在末尾添加静音,可选择固定时长或采样数。
  • 距离延迟: 延迟声音,使其如同传播了一段距离,以对齐扬声器。
  • 时间拉伸和音高偏移: 高质量地独立改变速度和音高。
  • 限制时长: 从开头最多保留这么多秒。
  • 修剪两端静音: 剪掉声音开始前和停止后的静音部分——不剪辑歌曲内部的静音。
  • 循环播放声音: 重复声音的某个片段。
  • 延迟声道: 将一个或多个声道延迟若干毫秒。
  • 移除静音: 剪掉静音片段。
  • 重采样: 改变声音的采样率。

立体声与声道 - 拓宽、声像、混合声道、耳机、环绕声

  • 对话增强器: 使电影混音中的语音突出。
  • 额外立体声: 增加左右声道之间的差异。
  • 耳机交叉馈送: 将每侧的一小部分混入另一侧,以缓解耳机听音疲劳。
  • 耳机立体声展宽: 拓宽立体声声场,专为耳机优化。
  • 混合声道: 用自定义系数重新混合声道:立体声转单声道,左右声道互换。
  • 加宽立体声: 通过延迟反馈使立体声图像更宽。
  • 立体声工具: 在一个滤镜中实现平衡、中侧电平、静音、相位等功能。
  • 上混到环绕声: 将立体声传播到环绕声布局中。
  • 声道: 交换左右声道,在两侧播放一个声道,将两者混合成一个,或将任何布局混音为立体声。
  • 声道去相关: 使声道之间的相似度降低,从而拓宽声音。
  • 重映射通道: 将通道移动到其他位置。
  • Haas 立体声增强器: 通过左右声道之间微小的延迟来拓宽声音。

音效 - 回声、合唱、移相、颤音、失真

  • 比特粉碎器: 降低声音的比特深度,以获得低保真、粗糙的效果。
  • 颤音: 使音量颤动。
  • 颤音: 使音高颤动。
  • 合唱: 用略微失谐的副本使声音变厚。
  • 回声: 为声音添加一个或多个回声。
  • 激励器: 通过增强高频来增加亮度。
  • 晶化器: 通过夸大声音的变化来锐化声音。
  • 脉冲器: 使电平脉冲化,立体声两侧交替进行。
  • 镶边: 添加一种扫掠的喷气式飞机般的效果。
  • 虚拟低音: 让小型扬声器听起来能播放更深的音符。
  • 移相器: 添加扫频移相效果。

无效果

效果下拉菜单的第一个选项,无效果,不是一个条目:它不执行任何操作。它不能被编辑或删除。

窗口:语言、主题、通知、新闻

标题栏中的齿轮图标会打开“设置”,其中包含上述的“预设”、“效果”、“标签”和“目标”选项卡,以及窗口本身的选项卡。

  • 打开设置 打开“设置”。
  • 语言 是窗口的语言。
  • 主题 是浅色 或 深色。
  • 显示来自 yaiol 的新闻 默认开启,涵盖下面描述的公告。
  • ffmpeg 显示已安装的 ffmpeg 版本以及 yaiol 提供的最新版本。下载 ffmpeg 安装它,更新 将其替换为最新版本;请参阅 ffmpeg,转换引擎。

ffmpeg,转换引擎

FFmpeg Audio Studio 不附带 ffmpeg,也从不使用您 PATH 中已有的 ffmpeg。它会下载 yaiol 批准的版本,检查并将其安装到所有 yaiol 应用程序共享的文件夹中,因此第二个需要它的应用程序会发现它已经存在。在安装之前,无法进行任何转换:状态行会显示此信息,并且 下载 ffmpeg 会开始下载,并显示进度。在此之前,效果菜单也是空的,因为效果是随 ffmpeg 提供的。

在设置的 常规 选项卡上,ffmpeg 会显示已安装的版本,并在询问 yaiol 后显示最新版本。当它们不同时,更新 会下载并安装较新的版本;如果无法联系到 yaiol,该行会显示此信息,您可以稍后再试。

运行结束时的通知

当不再有任何内容排队或转换时,一个操作系统通知会显示有多少文件已已转换、已跳过 和 失败。仅被取消的运行不会显示任何通知。无论窗口是否获得焦点,它都会出现。

  • 通知 选项卡上的 转换完成后显示通知 将其关闭。

新版本和新闻

启动时,应用程序会询问是否存在较新版本,如果存在,则会打开一个小型新闻对话框,其第一张卡片显示 新版本可用,其中包含版本信息,列出自您运行的版本以来每个版本的新增功能,并提供 下载。它只通知:不会自行安装任何东西,并且检查失败时会保持静默。同一个对话框会一次一张卡片地发布来自 yaiol 的偶尔公告。

  • 不再显示 会阻止该卡片再次出现;对于新版本卡片,直到有更新的版本发布。
  • 关闭 会关闭本次运行的对话框。
  • 设置中的 显示来自 yaiol 的新闻 会关闭公告,并且不会请求任何公告。新版本卡片不依赖于此设置。

命令行

安装程序在 FFmpeg Audio Studio 旁边放置了一个小程序 yac (yaiol audio converter),它可以在终端中执行相同的转换。它读取与窗口相同的已保存预设、标签设置、效果和目标,因此在窗口中创建的预设就是命令行上的预设,并且它写入的文件是相同的。

yac -p "MP3 320 kbps" -d Export Music/
yac -p FLAC -t Clean -o D:/Converted Album/
yac --list
  • 给予它文件和文件夹;文件夹及其子文件夹都会被搜索。
  • -p 指定一个已保存的预设(original 保留每个文件自己的格式),-t 指定一个已保存的标签设置,-e 指定一个已保存的效果条目,-d 指定一个已保存的目标。名称匹配不区分大小写,ID 也有效。
  • 如果省略 -t 和 -e,则表示不进行任何更改:保留所有标签和封面,不应用任何效果,无论窗口中选择了什么。如果省略 -p 和 -d,则使用窗口的当前选择。
  • -o 写入一个文件夹。与 -d 一起使用时,它是该目标的 文件名模式和文件夹结构,写入该文件夹。
  • -j 是同时运行的转换数量,最多可达机器的物理核心数,--overwrite 是 skip、overwrite 或 rename,-q 只打印失败和摘要。
  • --list 显示每个可以命名的内容,并标记窗口的当前选择。
  • 如果 ffmpeg 尚未安装,它会提示并停止:打开应用程序一次,它会自行安装 ffmpeg。

它为每个文件打印一行,并打印与窗口相同的摘要,例如 3 converted · 1 skipped · 2 failed。当没有失败时,退出代码为 0;当文件失败时为 1;当命令错误时为 2,因此脚本可以等待它并根据结果采取行动。

要从任何终端运行它,请勾选安装程序的最后一个选项,该选项会将其文件夹添加到您的 PATH 中,或者通过安装文件夹中的完整路径调用它。该选项默认关闭,并且只更改您自己的 PATH。

技术参考

为需要确切了解某个字段在何种格式中获得何种名称的人提供的事实。使用应用程序不需要这些。下表是从应用程序本身使用的表中生成的,因此它们不会偏离。

按标签标准划分的字段名称

每行一个字段,每列一个标准。每个单元格是该字段在此处的名称:一个 ID3 帧 ID、一个 MP4 atom、一个 WMA 属性、一个 Vorbis 注释或 APE 项目名称,或一个 WAV INFO ID。破折号表示该标准没有自己的字段名称;应用程序会将其保留为自定义字段,使用字段本身的名称,因此值不会丢失。

Field            ID3v2.3  ID3v2.4  MP4 atom  WMA attribute               Vorbis / APE     WAV INFO
---------------  -------  -------  --------  --------------------------  ---------------  --------
ALBUM            TALB     TALB     ©alb      WM/AlbumTitle               ALBUM            IPRD
ALBUMSORT        TSOA     TSOA     soal      WM/AlbumSortOrder           ALBUMSORT        -
ALBUMARTIST      TPE2     TPE2     aART      WM/AlbumArtist              ALBUMARTIST      -
ALBUMARTISTSORT  TSO2     TSO2     soaa      -                           ALBUMARTISTSORT  -
ARTIST           TPE1     TPE1     ©ART      Author                      ARTIST           IART
ARTISTSORT       TSOP     TSOP     soar      WM/ArtistSortOrder          ARTISTSORT       -
BPM              TBPM     TBPM     tmpo      WM/BeatsPerMinute           BPM              -
COMMENT          COMM     COMM     ©cmt      Description                 COMMENT          ICMT
COMPILATION      TCMP     TCMP     cpil      -                           COMPILATION      -
COMPOSER         TCOM     TCOM     ©wrt      WM/Composer                 COMPOSER         -
COMPOSERSORT     TSOC     TSOC     soco      -                           COMPOSERSORT     -
CONDUCTOR        TPE3     TPE3     ©con      WM/Conductor                CONDUCTOR        -
CONTENTGROUP     TIT1     TIT1     ©grp      WM/ContentGroupDescription  CONTENTGROUP     -
COPYRIGHT        TCOP     TCOP     cprt      Copyright                   COPYRIGHT        ICOP
DISCNUMBER       TPOS     TPOS     disk      WM/PartOfSet                DISCNUMBER       -
ENCODEDBY        TENC     TENC     ©enc      WM/EncodedBy                ENCODEDBY        -
ENCODERSETTINGS  TSSE     TSSE     -         WM/EncodingSettings         ENCODERSETTINGS  -
GENRE            TCON     TCON     ©gen      WM/Genre                    GENRE            IGNR
INITIALKEY       TKEY     TKEY     -         WM/InitialKey               INITIALKEY       -
ISRC             TSRC     TSRC     -         WM/ISRC                     ISRC             -
LANGUAGE         TLAN     TLAN     -         WM/Language                 LANGUAGE         ILNG
LYRICIST         TEXT     TEXT     -         WM/Writer                   LYRICIST         -
MEDIATYPE        TMED     TMED     -         -                           MEDIATYPE        -
MIXARTIST        TPE4     TPE4     -         -                           MIXARTIST        -
MOOD             -        TMOO     -         WM/Mood                     MOOD             -
ORIGALBUM        TOAL     TOAL     -         WM/OriginalAlbumTitle       ORIGALBUM        -
ORIGARTIST       TOPE     TOPE     -         WM/OriginalArtist           ORIGARTIST       -
ORIGLYRICIST     TOLY     TOLY     -         WM/OriginalLyricist         ORIGLYRICIST     -
ORIGYEAR         TORY     -        -         WM/OriginalReleaseYear      ORIGYEAR         -
PUBLISHER        TPUB     TPUB     ©pub      WM/Publisher                PUBLISHER        -
SUBTITLE         TIT3     TIT3     -         WM/SubTitle                 SUBTITLE         -
TITLE            TIT2     TIT2     ©nam      Title                       TITLE            INAM
TITLESORT        TSOT     TSOT     sonm      WM/TitleSortOrder           TITLESORT        -
TRACK            TRCK     TRCK     trkn      WM/TrackNumber              TRACKNUMBER      IPRT
UNSYNCEDLYRICS   USLT     USLT     ©lyr      WM/Lyrics                   UNSYNCEDLYRICS   -
YEAR             TYER     TDRC     ©day      WM/Year                     DATE             ICRD

每种格式使用的标准

每种输出格式都将其标签写入为上述标准之一。最后一列说明了上表中哪一列命名了其中的字段。

Format                 Extension  Tags are written as                                          Names from
---------------------  ---------  -----------------------------------------------------------  ------------------------
AAC (M4A)              .m4a       MP4 atoms                                                    MP4 atom column
AAC (raw ADTS)         .aac       none (a raw stream)                                          -
AC-3                   .ac3       none (a raw stream)                                          -
AIFF                   .aiff      an ID3v2.3 or v2.4 chunk (the preset)                        ID3 columns
ALAC (M4A)             .m4a       MP4 atoms                                                    MP4 atom column
AU                     .au        an annotation field: title, artist and album only            -
FLAC                   .flac      Vorbis comments                                              Vorbis / APE column
FLAC in Ogg            .oga       Vorbis comments                                              Vorbis / APE column
M4R (iPhone ringtone)  .m4r       MP4 atoms                                                    MP4 atom column
MP2                    .mp2       none (a raw stream)                                          -
MP3                    .mp3       ID3v2.3 or v2.4 (the preset)                                 ID3 columns
Ogg Vorbis             .ogg       Vorbis comments                                              Vorbis / APE column
Opus                   .opus      Vorbis comments                                              Vorbis / APE column
TTA                    .tta       APEv2 tag                                                    Vorbis / APE column
WAV                    .wav       an ID3v2.3 or v2.4 chunk (the preset), and a RIFF INFO list  ID3 columns; INFO column
Wave64                 .w64       none (a raw stream)                                          -
WavPack                .wv        APEv2 tag                                                    Vorbis / APE column
WMA                    .wma       WMA attributes                                               WMA column

注意事项

  • 没有自己名称的字段 将作为自定义字段保留:ID3 中的 TXXX 帧、M4A 中的自由格式 atom (----:com.apple.iTunes:NAME)、Vorbis 或 APE 标签中同名的项目、WMA 中同名的属性。
  • 一个没有名称的 ID3 版本。 ID3v2.3 没有 mood 帧,ID3v2.4 将原始发行版保留为时间戳 (TDOR) 而不是文本帧,因此这两个单元格是破折号,并且该值在该版本中作为自定义字段保留。
  • 日期。 ID3v2.3 将日期存储为年份 (TYER) 和日、月 (TDAT);ID3v2.4 有一个时间戳 (TDRC)。Vorbis 或 APE 标签将其保留为 DATE。
  • 音轨和光盘编号。 总数是 ID3 和 MP4 中编号的一部分 (3/10);Vorbis 标签将 TRACKNUMBER 和 TRACKTOTAL 保留为两个字段。
  • WAV INFO。 仅携带最后一列中有名称的 ID;没有名称的 ID 将被丢弃,因为当标签器写入时,相同的值存在于 ID3 块中。
  • 排序字段和指挥。 ALBUMSORT 和 CONDUCTOR 等名称在每个 Vorbis 输出中都以相同的方式写入;从 ID3 TPE3 帧读取的指挥被写入为 CONDUCTOR,而不是 PERFORMER。
  • 封面。 除了 Ogg 中的 FLAC、iPhone 铃声和 AU 之外,所有写入标签的格式都携带封面;原始流不包含任何封面。
目录